UVa 12784 - Don't Care

contents

  1. 1. Problem
  2. 2. Sample Input
  3. 3. Sample Output
  4. 4. Solution

Problem

問是否計算順序會影響結果,給一個有向圖,請問是否每一個操作都會 reduce 到同一個項目。

Sample Input

1
2
3
4
5
6
7
8
9
10
11
12
13
3 2
0 1
1 2
2 2
0 1
0 1
2 2
0 1
1 0
3 2
0 1
0 2
0 0

Sample Output

1
2
3
4
1
1
0
0

Solution

如果裡面有環肯定是不行的,因此需要偵測環是否存在。

在這之後,必須檢查是否會 reduce 到同一個項目,因此我們將每個 node reduce 的結果保存,之後取聯集,如果發現 reduce 項目超過一個則直接回傳失敗。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
#include <stdio.h>
#include <string.h>
#include <vector>
#include <set>
#include <algorithm>
using namespace std;
vector<int> g[1024];
set<int> A[1024];
int used[1024];
int instk[1024];
int dfs(int u) {
used[u] = 1, instk[u] = 1;
for (int i = 0; i < g[u].size(); i++) {
int v = g[u][i];
if (instk[v])
return 1;
if (!used[v]) {
if(dfs(v))
return 1;
A[u].insert(A[v].begin(), A[v].end());
if (A[u].size() > 1)
return 1;
}
}
if (g[u].size() == 0)
A[u].insert(u);
instk[u] = 0;
return A[u].size() > 1;
}
int main() {
int n, m, x, y;
while (scanf("%d %d", &n, &m) == 2 && n) {
for (int i = 0; i < n; i++)
g[i].clear(), used[i] = 0, A[i].clear(), instk[i] = 0;
int indeg[1024] = {};
for (int i = 0; i < m; i++) {
scanf("%d %d", &x, &y);
g[x].push_back(y);
indeg[y]++;
}
int err = 0;
for (int i = 0; i < n && !err; i++) {
if (used[i] == 0 && indeg[i] == 0)
err |= dfs(i);
}
for (int i = 0; i < n; i++) // cycle
if (used[i] == 0)
err = 1;
printf("%d\n", !err);
}
return 0;
}
/*
3 2
0 1
1 2
2 2
0 1
0 1
2 2
0 1
1 0
3 2
0 1
0 2
0 0
*/