UVa 12707 - Block Meh

contents

  1. 1. Problem
  2. 2. Sample Input
  3. 3. Sample Output
  4. 4. Solution

Problem

給 N 個區間 [l, r],每一次挑選一個區間 [a0, b0],接著可以找到另外一個區間 [ai, bi][a0, b0] 完全覆蓋 (a0 < ai < bi < b0),接著再對這個區間 [ai, bi] 再找一個被完全覆蓋的區間 [ai+1, bi+1] 如此迭代下去,當作一次操作。

請問至少要幾次,才能將所有區間挑選完。

Sample Input

1
2
3
4
5
6
7
8
9
10
11
2
4
1 5
2 5
3 5
3 4
4
1 5
2 4
3 5
3 3

Sample Output

1
2
Case 1: 3
Case 2: 2

Solution

對右端點進行遞增排序,對左端點進行次遞增排序,接著進行掃描算法,每一次放入的區間盡可能被之前的區間包含住,否則將會增加一次操作,也就是說要找盡可能接近的左端點來符合放入的區間。

這個操作方式,非常接近 O(n log n) LIS 的思路。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
#include <stdio.h>
#include <math.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <string.h>
#include <assert.h>
using namespace std;
bool cmp(pair<int, int> a, pair<int, int> b) {
if (a.second != b.second)
return a.second < b.second;
return a.first < b.first;
}
#define INF 0x3f3f3f3f
int main() {
int testcase, cases = 0;
int n, s, e;
scanf("%d", &testcase);
while (testcase--) {
scanf("%d", &n);
vector< pair<int, int> > D;
for (int i = 0; i < n; i++) {
scanf("%d %d", &s, &e);
D.push_back(make_pair(s, e));
}
sort(D.begin(), D.end(), cmp);
vector<int> leftside;
for (int i = 0; i < D.size(); i++) {
int pos = (int)(lower_bound(leftside.begin(), leftside.end(), D[i].first + 1)
- leftside.begin());
if (pos == leftside.size()) {
leftside.push_back(D[i].first);
} else {
leftside[pos] = D[i].first;
}
}
printf("Case %d: %d\n", ++cases, (int)leftside.size());
}
return 0;
}