UVa 12874 - Blanket

contents

  1. 1. Problem
  2. 2. Sample Input
  3. 3. Sample Output
  4. 4. Solution

Problem

寒冷的冬天,為街道上的人鋪設毛毯,現在有 n 個無限長毛毯,每一個毛毯都有其紋路,呈現厚薄厚薄厚薄 … 的順序,其中厚的長度為 ai,而薄的長度為 bi - ai。

現在長度為 1…m 的街道,請問蓋到 1 件、2 件、3 件、 …、n 件薄毛毯的人分別有多少人。

Sample Input

1
2
3
4
5
1
3 30
2 5
3 5
3 6

Sample Output

1
2
3
4
6
9
9
6

Solution

看到 ai, bi <= 16。

窮舉每個人,O(16) 計算蓋到幾件薄毛毯。

如果用 O(nm) 顯然太慢,由於 bi 很小,針對所有可能,預建表得到循環下累計結果。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
#include <stdio.h>
inline int readchar() {
const int N = 1048576;
static char buf[N];
static char *p = buf, *end = buf;
if(p == end) {
if((end = buf + fread(buf, 1, N, stdin)) == buf) return EOF;
p = buf;
}
return *p++;
}
inline int ReadInt(int *x) {
static char c, neg;
while((c = readchar()) < '-') {if(c == EOF) return 0;}
neg = (c == '-') ? -1 : 1;
*x = (neg == 1) ? c-'0' : 0;
while((c = readchar()) >= '0')
*x = (*x << 3) + (*x << 1) + c-'0';
*x *= neg;
return 1;
}
int ret[131072];
int main() {
int testcase, n, m;
// scanf("%d", &testcase);
ReadInt(&testcase);
while (testcase--) {
// scanf("%d %d", &n, &m);
ReadInt(&n);
ReadInt(&m);
int A[20][20] = {}, a, b;
for (int i = 0; i < n; i++) {
// scanf("%d %d", &a, &b);
ReadInt(&a);
ReadInt(&b);
A[b][a]++;
}
for (int i = 1; i <= 16; i++) {
for (int j = 1; j <= 16; j++)
A[i][j] += A[i][j-1];
}
for (int i = 0; i <= n; i++)
ret[i] = 0;
for (int i = 0; i < m; i++) {
int cover = 0;
for (int j = 1, t; j <= 16; j++) {
t = i%j;
cover += A[j][16] - A[j][t];
}
ret[cover]++;
}
for (int i = 0; i <= n; i++)
printf("%d\n", ret[i]);
}
return 0;
}
/*
9999
3 30
2 5
3 5
3 6
2 15
1 2
3 4
*/