UVa 1086 - The Ministers' Major Mess

contents

  1. 1. Problem
  2. 2. Sample Input
  3. 3. Sample Output
  4. 4. Solution

Problem

有 M 個人,B 個方案要進行投票表決。

每個人可以選擇 ki 個方案進行通過或不通過,其中 ki <= 4。找到一種方案的通過方式滿足所有人選擇項目的一半以上 (不含)。

Sample Input

1
2
3
4
5
6
7
5 2
4 2 y 5 n 3 n 4 n
4 4 y 3 y 5 n 2 y
4 2
4 1 y 2 y 3 y 4 y
3 1 n 2 n 3 n
0 0

Sample Output

1
2
Case 1: ?y??n
Case 2: impossible

Solution

由於 ki <= 4,又要滿足一半以上。則對於 ki = 1, 2 需要全部符合他們的項目。對於 ki = 3, 4 則不滿足其中一個選項 i 時,其他的選項 j 都必須滿足。

藉此套用 2-sat 模型,找到是否可能有可行解。當要輸出 2-sat 其中一解時,窮舉每一個變數為 true / false,建立一條邊 x -> x' / x' -> x,再用 2-sat 模型判斷是否有解即可。

找解速度會慢很多,這樣會比較好撰寫。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
// 2-satisify problem
#include <stdio.h>
#include <stdlib.h>
#include <vector>
#include <algorithm>
#include <string.h>
using namespace std;
const int MAXN = 262144;
class TwoSat {
public:
int n;
vector<int> g[MAXN];
// <SCC begin>
int vfind[MAXN], findIdx;
int stk[MAXN], stkIdx;
int in_stk[MAXN], visited[MAXN];
int contract[MAXN];
int scc_cnt;
// <SCC end>
int scc(int u) {
in_stk[u] = visited[u] = 1;
stk[++stkIdx] = u, vfind[u] = ++findIdx;
int mn = vfind[u], v;
for(int i = 0; i < g[u].size(); i++) {
v = g[u][i];
if(!visited[v])
mn = min(mn, scc(v));
if(in_stk[v])
mn = min(mn, vfind[v]);
}
if(mn == vfind[u]) {
do {
in_stk[stk[stkIdx]] = 0;
contract[stk[stkIdx]] = u;
} while(stk[stkIdx--] != u);
scc_cnt++;
}
return mn;
}
void addEdge(int u, int v) { // u -> v
g[u].push_back(v);
}
int solvable() {
for (int i = 0; i < n; i++)
visited[i] = in_stk[i] = 0;
scc_cnt = 1;
for (int i = 0; i < n; i++) {
if (visited[i]) continue;
stkIdx = findIdx = 0;
scc(i);
}
for(int i = 0; i < n; i += 2)
if(contract[i] == contract[i^1])
return 0;
return 1;
}
void computeChoice() {
if (!solvable())
return ;
for (int i = 0; i < n; i += 2) {
int val = 0;
g[i].push_back(i^1);
if (solvable()) val |= 1;
g[i].pop_back();
g[i^1].push_back(i);
if (solvable()) val |= 2;
g[i^1].pop_back();
printf("%c", "-yn?"[val]);
}
puts("");
}
void init(int n) {
this->n = n;
for (int i = 0; i < n; i++)
g[i].clear();
}
} g;
// more than half of his or her opinions satisfied
// opinion <= 4
int main() {
int n, m, cases = 0;
char s[128];
while (scanf("%d %d", &n, &m) == 2 && n) {
g.init(2 * n);
for (int i = 0; i < m; i++) {
int vote[8], k, x;
scanf("%d", &k);
for (int j = 0; j < k; j++) {
scanf("%d %s", &x, s);
x--;
vote[j] = x * 2 + (s[0] == 'y');
}
if (k <= 2) { // all satisfied
for (int p = 0; p < k; p++)
g.addEdge(vote[p]^1, vote[p]);
} else { // one fail
for (int p = 0; p < k; p++) {
for (int q = 0; q < k; q++) {
if (p == q) continue;
// p-th opinion fail
g.addEdge(vote[p]^1, vote[q]);
}
}
}
}
printf("Case %d: ", ++cases);
if (!g.solvable()) {
puts("impossible");
} else {
g.computeChoice();
}
}
return 0;
}