UVa 13054 - Hippo Circus

contents

  1. 1. Problem
  2. 2. Sample Input
  3. 3. Sample Output
  4. 4. Solution

Problem

馬戲團河馬過門,單一隻河馬過門需要時間 $T_a$,兩隻河馬疊在一起且滿足總高度小於 $H$,需要花費 $T_b$ 的時間。

不管任何順序過門,請問最少時間為何?

Sample Input

1
2
3
4
5
2
3 5 2 3
3 4 2
3 6 2 3
3 4 2

Sample Output

1
2
Case 1: 6
Case 2: 5

Solution

明顯地,最矮的那隻盡量跟最高的那隻配在一起過門,反之考慮分開過門,看哪一種好就選擇哪一種。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
#include <bits/stdc++.h>
using namespace std;
int A[131072], used[131072];
int main() {
int testcase, cases = 0;
scanf("%d", &testcase);
while (testcase--) {
int N, H, Ta, Tb;
scanf("%d %d %d %d", &N, &H, &Ta, &Tb);
for (int i = 0; i < N; i++)
scanf("%d", &A[i]);
sort(A, A+N);
long long ret = 0;
memset(used, 0, sizeof(used));
int r = N-1;
for (int i = 0; i < N; i++) {
if (used[i] == 1) continue;
while (r > i && (A[i] + A[r] >= H || used[r] == 1))
r--;
if (r > i && A[i] + A[r] < H && used[r] == 0 && Ta+Ta > Tb) {
ret += Tb;
used[r] = used[i] = 1;
} else {
ret += Ta;
used[i] = 1;
}
}
printf("Case %d: %lld\n", ++cases, ret);
}
return 0;
}